yolobs-studio/debian/patches/0002-Hide-internal-symbols.patch
Sebastian Ramacher f343962e1e Refresh patches
2018-12-16 17:18:48 +01:00

37 lines
923 B
Diff

From: Sebastian Ramacher <sramacher@debian.org>
Date: Wed, 19 Apr 2017 21:45:40 +0200
Subject: Hide internal symbols
---
libobs/CMakeLists.txt | 4 ++++
libobs/util/c99defs.h | 2 +-
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/libobs/CMakeLists.txt b/libobs/CMakeLists.txt
index bddfa5c..41ed749 100644
--- a/libobs/CMakeLists.txt
+++ b/libobs/CMakeLists.txt
@@ -463,6 +463,10 @@ if(NOT MSVC)
-msse2)
endif()
+if(UNIX)
+ set_source_files_properties(${libobs_SOURCES} PROPERTIES
+ COMPILE_FLAGS "-fvisibility=hidden")
+endif()
target_compile_options(libobs
PUBLIC
diff --git a/libobs/util/c99defs.h b/libobs/util/c99defs.h
index c4ee627..d26b3dd 100644
--- a/libobs/util/c99defs.h
+++ b/libobs/util/c99defs.h
@@ -46,7 +46,7 @@
#define EXPORT __declspec(dllexport)
#else
-#define EXPORT
+#define EXPORT __attribute__((visibility("default")))
#endif
#if _MSC_VER && _MSC_VER < 0x0708