yolobs-studio/debian/patches/0004-Link-with-libm-and-libdl-to-fix-underlinking.patch
Sebastian Ramacher ab10ec5384 Refresh patches
2018-02-19 21:07:10 +01:00

24 lines
630 B
Diff

From: Sebastian Ramacher <sramacher@debian.org>
Date: Wed, 19 Apr 2017 22:44:48 +0200
Subject: Link with libm and libdl to fix underlinking
---
libobs/CMakeLists.txt | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/libobs/CMakeLists.txt b/libobs/CMakeLists.txt
index c82d94e..83dcb75 100644
--- a/libobs/CMakeLists.txt
+++ b/libobs/CMakeLists.txt
@@ -205,6 +205,11 @@ elseif(UNIX)
${PULSEAUDIO_LIBRARY})
endif()
+ set(libobs_PLATFORM_DEPS
+ ${libobs_PLATFORM_DEPS}
+ m
+ dl)
+
if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
# use the sysinfo compatibility library on bsd
find_package(Libsysinfo REQUIRED)