103fad448f
* debian/patches: - Use the SIMD Everywhere headers from libsimde-dev, instead of upstream's code copy * debian/control - Build-dep on libsimde-dev - Add "Built-Using: ${simde:Built-Using}" to all the binary packages to document the version of libsimde-dev used, as required to keep that version in the Debian archive, which is needed to fulfill the GPL * debian/copyright: - exclude libobs/util/simde/* as we will use the files from libsimde-dev * debian/rules: - Include the recommended flags for SIMDe, especially important for non-X86 architectures
13 lines
364 B
Diff
13 lines
364 B
Diff
Author: Michael R. Crusoe <michael.crusoe@gmail.com>
|
|
Subject: Use the simd everywhere headers from libsimde-dev
|
|
--- obs-studio.orig/libobs/util/sse-intrin.h
|
|
+++ obs-studio/libobs/util/sse-intrin.h
|
|
@@ -19,7 +19,7 @@
|
|
|
|
#if NEEDS_SIMDE
|
|
|
|
-#include "simde/sse2.h"
|
|
+#include <simde/x86/sse2.h>
|
|
|
|
#define __m128 simde__m128
|
|
#define _mm_setzero_ps simde_mm_setzero_ps
|