--- a/configure.ac
+++ b/configure.ac
@@ -1065,7 +1065,7 @@ dnl Override installation directory, wit
 dnl prefix. This is needed for 'distcheck*' targets, otherwise
 dnl files will try to get intalled to the actual system directories
 if test -n "${systemdsystemunitdir}"; then
-	systemdsystemshutdowndir="${libdir}/systemd/system-shutdown"
+	systemdsystemshutdowndir=`$PKG_CONFIG --variable=systemdshutdowndir systemd`
 	AC_MSG_RESULT(using ${systemdsystemunitdir})
 else
 	AC_MSG_RESULT(no)