32 REALTEK

Build Environment Setup — IAR

This document illustrates how to build Realtek Wi-Fi SoC software under IAR SDK
environment.
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1 How to get IAR

IAR provides an IDE environment for code building, downloading, and debugging. Please check
“IAR Embedded Workbench” on http://www.iar.com/, and trail version is available.

2 Ameba-Z Hardware Configuration

Hardware block diagram is shown in Figure 2-1 Hardware block diagram. The block USB UART
is used to supply power and catch logs, UART baud is 115200. SWD means J-Link SWD interface,
when it is connected to J-Link Adapter correctly, you can download images to Ameba-Z from
IAR flash downloader. Reset button is used to reset Ameba-Z to run firmware after IAR
completes downloading.

Reset button
! WIFI external ant

x

Moo (OS]
i I, !

DAP update
mode button

3 i RS
USB Device [N

...........

B8 RTLE710B e

== | : BRI ART LOG: [
b prre7 Rl o PA29&PA30
. =5 - »‘: L. ~al| Download image
DAP reset ) 3 8 K button

button

Figure 2-1 Hardware block diagram

The Dupont Line diagram between J-Link Adapter and Ameba-Z SWD is as follows:
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100
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000

MM
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Figure 2-2 J-Link SWD connection

Please notice that DAP chip is not welding on the Ameba-Z demo board and so DAP function is
not enabled which means MBED u disk copy is disabled.

Physical connection as shown below:

Figure 2-3 Physical connection

3 How to build and download code

Please make sure USB UART is connected to PC with USB line and SWD is connect to J-Link
Adapter with Dupont Line before download code.

May 2, 2017
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3.11AR build

Step 1: Open IAR Workbench

Step 2: To open project, click File > Open = Workspace

cl
Edlt View Project Tools Window Help

= = oam
Mew v | Y eEIr e R EH|BERL|L D
Open » File. Ctrl+0 f) = x
Save Workspace Header/Source File Ctrl+Shift+H vy 7 vy y
Close Workspace r ( (
RN AR RN RN RN RRA R RRRRRRRRRRY

Save Ctrl+S
Save As
Save All
Page Setup.
Print Ctrl+P
Recent Files 3
Recent Workspaces 3
Exit

Guidelines for setting up Complete product Example applications

your projed, adding documentstion in FDF that demonsirate Information and

files. comepiling. linking. farmat gives you all the hardware peripherals for example projects for

snd debugging it. user and reference specific devices and integrated RTOS and

information you need. evalustion boards. migdleware solutions.

Tutorials fo make you For questions about how Al about the latest Here you can downlead

familiar with the IDE to use your IAR product, festures, new device product updates,

and the features of the reporting a problem, or support, and program manage licenses ang

IAR C-SPY debugger. finding support comections contact informaticn, snd

resources. check your SUA status.
« 1. r -
Open a Workspace NUM

Step 3: Select Project.eww in project\realtek_amebaz_va0_example\EWARM-RELEASE

Click Project = Options, General Options->Target->Processor Variant->Core, make sure you
have chosen Cortex-M4f. If your IAR not support this core, Please choose Cortex-M4 and
Floating point settings->FPU is set to “VFPv4 single precision”.
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& Project - IAR Embedded Workbench IDE | = |6 29 |
File Edit View Project Tools Window Help
. - = < nop
Dwdd & fB2Ro o VY% ZE D @ P 40 0
Workspace x - x
Debug -
Files Enomy
E}&]Project - Debug v | ]
Olapp . ' .
[ console
ik
[ netwark Btz
[dos
[ peripheral
& Juser s ek
untime Checking
+] 7 5 7 7 7 .
g uOt:JllttF;eu? CJC++ Compiler Target |Dutput I Library Configuration I Library Options I [ I '
Assembler
Ouh:iutCowerter Frocessor wariant
Custom Build
Buld Actions © Core
Linker —
I Debuager ) Dewice |Nonedefault Hone | |E|
Simulataor
Angel
I CMSIS DAP Endian mode Floating point settings
GDEB Server @ Little FFU [¥FEv4 single precisi v
IAR. ROM-monitaor 1 Big
I4et/TTAGjEt J— ] 18 =]
J-Llnk4|’|J—'I_'race @ BEg
I Stellaris [ Advanced SIND (HEOH)
Macraigor
PE micra
RDI
ST-LINK.
Third-Party Driver
Praject
l TLXDS I ak I [ Cancel
Ready

Step 4: To build project, click Project = Rebuild All

Then you will get boot_all.bin and image2_all_otal.bin in
project\realtek_amebaz_va0O_example\EWARM-RELEASE \Debug\Exe.
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rﬁ Project - IAR Embedded Workbench IDE E‘éﬁ
File Edit Wiew | Project | CMSIS-DAP Tools Window Help
D a| Add Files... ‘Y uEP &P @
Warkspace Add Group... X
[Dehug Impaort File List...
Files Add Project Connection...
Bl (F Project - [ Edit Configurations...
[demsis
[Jconsole lzmze
g :t;twmk Create Mew Project...
Clos Add Existing Praoject...
5
O heherl options.. A7
— CISDRAM Wersion Contral System 3
[Quser
(3 Output Make F7
Compile Ctrl+F7
| Rebuildal
Clean
Batch build... F&
Stop Build Ctrl+Break
Download and Debug Ctrl+D
Debug without Downloading
Make B Restart Debugger Ctrl+R
Restart Debugger Ctrl+Shift+R
Download »
SFR Setup
lm Open Device Description File 3
Clean and make the Save List of Registers...

Step 5: To build image2_all_ota2.bin for OTA, click Project->Options->Build Actions->Build
Actions Configuration->Pre-build command line, change the secondary parameter “1” to “2”
shown as follows, then Click OK and make project “Rebuild All”.

Then you will get image2_all_ota2.bin in project\realtek_amebaz_va0_example\EWARM-

RELEASE \Debug\Exe.
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Options for nade TProject - -

Categan,:

General Options
Static Analysis

Runtime Checking
C/C ++ Compiler Euild Aetions Configuration |

"o

Aszembler
Pre-build d line:
Qutput Converter LELLL mommenc ~ine

Custom Build Aityhcommonhprebuild. wbs”| “EPROT_DIRG” “0x08080000° [,

Build Actions Fost-build command line:
|

Linker CSCEIFT  “$PEOT_DIRES. . % . % . \componenthsocirealtekhST: [:]
Debugger
Simulator
Angel
CMSIS DAP
GDE Server
IAR. ROM-monitor
THjet/TTAGjet
JLink/1-Trace
TI Stellaris
Macraigor
PE micra
ROI
ST-LIMNK
Third-Party Driver

TIXDS [ ok ][ Cancel ]

By the way, the mbed APIs include C files and Header files used by Ameba-Z is located in
component\soc\realtek\8711b\mbed\. It will also be merged to component\common\mbed\ in
next version. Now if you use Ameba-1, please choose files from component\common\mbed\
and if you use Ameba-Z, please choose files from component\soc\realtek\8711b\mbed\.

May 2, 2017 8



Si2 REALTEK

Document Number: UM0110

| Project

/* Execute application example *#/
1

" — — ———
& Project - IAR Embedded Workbench IDE ARl X
File Edit View Project Tools Window Help
DEdd & \ | - Y PP
2 | main.c | main() + X
[Debug A = —
- . -
Files £ - * gbrief Main program.
* fparam None
E s - * gretval None
e — a
| -- void main(wvoid)
analogin_api.c =M
[ dma_api.c uint32_t *p = {uint32_t*)0x10005010:
efuse_api.c
[E1 flash_api.c *p = 32;
gpio_api.c printf ("\np=td\n", *p);
gpin_irg_api.c ) S
iZC_apiC = = if ( rtl_cryptoEngine_init() != 0 ) |
B izs apic DiagPrintf("crypto engine init failed\r\n"); |_
nfc_api.c }
a1 [ i
e p!nmap.c /* Initialize log uart and at command service */
pihmagp_commaon.c //console imit() s
port_api.c . ReRegiste;Plat:'crmchUart {:
pwmout_api.c A
nC__aF”-C ) /* pre-processor of application example */
setial_apic pre_example_entry(): —
sleep o
I spi_spic /* wlan intislization */
Sys_aplc [H #if defined(CONFIG_WIFI_NORMAL) ss& defined(CONFIG_NETWORK)
t\mer_apl.c wlan network():
us_ticker.c I #endif
[Clus ticker api.c o

1

X 1

3.21AR download

The Ameba-Z demo board only supports JLINK SWD download and debug.

Please note that if you want use IAR download image to debug, please set the secondary

parameter of prebuild.bat to “1” and build.

Step 1: Please check J-link debugger is setting correct. Click Project->Options->Debugger-
>Setup->Driver, and choose “J-Link/J-Trace”. Then click Debugger-> J-Link/J-Trace->Connection-

>Interface and choose “SWD”.
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3@ Project - IAR Embedded Workbench IDE |_‘:' =l P
File Edit View Options fer node "Project” - u
Dieb :

Files General Options
=] Ij Static Analysis
Cla Runtime Checking
0 Cfﬂ[‘i"is CJC++ Compiler Setup |Do'wnload | Inages I Extra Options I Malticore I Pluginsl
Cconsole Assembler ;
Ol Output Converter Driver Run to
Cusomptd | ||| | oo
I network I
Build Actions
Mos Linker Setup macraos
[ peripherg| [¥]Use macro file(s)
[user Simulator $FPROT_DIESY. . % % hcomponenthsocirealtelthdT11b4mi E]
Jutilities Angel
3 Output CMSIS DAP E]
GDB Server . L .
TAR ROM-monitor Device description file
IHet/ITAGjet Owerride defanlt
J-ink{1-Trace FPROT_DIESY. . % % . hcomponenthsocirealtelh8T11b4m1 E]
TI Stellaris
- Macraigor
[ Project PE micro
x ROI
Messages ST-LINK
- Third-Farty Driver
Linking TS
/Ay warming[Lal [ 0K ] ’ Cangel
"zi section
A\ waming[Lp : .
data section image . validate rodata in startup.o symbols: [RAM_IMGZ_WVALID_FPATTEMN]"
Perfarming Post-Build Action
F
Total number of errars: 0 :I
= e TP T N VY JRPUR ol
4 = BN 1 3
Ready Errors 0, Warnings 57
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T —
& Project - IAR Embedded Workbench IDE |_‘:' CIR
- . . -
i Options for node "Project™ ﬂ
nE=a=N-
r—
Debu : -
g Category: Factory Settings
Files General Options
© TR | (e wabss
Runtime Checking
] .
g Elfniis C/C++ Compiler Connection |Erealpoints
] console Assembler C ication
3l QOutput Converter Dlewice O * Serial
Custom Build
(&) : IF addr
[ netwiark. Build Actions (7) TCR/IF: address
HE[Jos Linker IF address: |aaa bbb, cce. ddd Serial
[ peripherg
REnR Debugger Interface JTAG =zcan chain
Cluser Simulator
7 utilities Angel @ TIa JTAG =can chain with multiple tar
3 Output CMSIS DAP @ 0 TAE munber: |0
GOE Server o Secan chain contains non—AREM dewice
TAR ROM-monitor Frecesding o
Ijet/ITAGjet
Hink/1-Trace D Log communication
1 T1 Stellaris FPEOT_IIRF\cspycomm. Loz
- Macraigor
| Praject PE micro
. RDI
Messages ST-LINK
- Third-Farty Driver
Linking TI¥0S
M, warning[Lall Ok ] ’ Caneel
"zi section .
M\ warning[Lp " c
data section .image2.validate.rodata in startup.o symbols: [RAM_IMGZ_WALID_PATTEN]"
Ferforming Post-Build Action
w
Tatal number of errars: 1 jl
= T S
= RN m 3
Ready Errors 0, Warnings 57

Step 2: To download code, click Project->Download->Download active application.
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r — o - 5
& Project - IAR Embedded Workbench IDE oo =
File Edit Wiew |Project| Tools Window Help
Add Files... LYY
Add Group... - X
Import File List...
Files Add Project Connection...
=¥u|Project - [ Edit Configurations...
Clapp
I [Jcmsis Rz
g ﬁgnsole Create Ne'w P‘rcg'e-ect...
T netwark Add Existing Praoject...
[os .
' Options... Alt+F7
! & [ peripher s *
Ouser Version Control System 3
[ utilities
3 Output Make F7
Compile Ctrl+F7
i Rebuild All
Clean
Batch build... F8
| Projsct C-STAT Static Analysis v
x
Messages Stop Build Ctrl+Break o
Linking
& Warning[Ly Download and Debug example "rw data section image entry.da
"oi section Debug without Downloading
I A WaminglL Make & Restart Debugger ctel+R Imple "ri data section image2 entry.data in
data Se'.jm Restart Debugger Ctrl+Shift+R GZ_VALID_PATTEN]")
Ferfarming
Download 3 Download active application Ctrl+D
- I?t?! numll: SFR Setup Download file...
=l Erase memary
— = Open Device Description File b g

After firmware download, click Reset button to reboot the system.

3.3 1AR debug

To debug or trace code step by step, click Project > Download and Debug or press one of the

two buttons & L in the IAR menu.

Upper left corner of the toolbar shows step by step tracking tools.

May 2, 2017
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3 Project - IAR Embedded Workbench p—
File Edit View Project Debug Disassembly J-Link Tools Window Help
D@ S| s 2R o | YR e SRS
|z‘5v| L 22 L2852 X
AEEED|
Workspace E v y Dssssmbly  x
[Debug - Goto -
Files i Disassembly s
B @ Project-D... « ]
& Clapp 0x104: 0x6
& 1 cmsis 0=106: O=xf
& C1 consale 0zl0a: 06
= Clikb Oxl0c: 0Oxf
& C1 network 0=110: 0O=f
[os Oxll4: 0Oxf
—# O petipheral 0xlld: 0xf
HH Cluser Oxllc: 0xk
& C utilities Oxlle: 0Oxf
L= 71 Qutput 0xl22: Oxf
0xl26: 0=t
Oxlza: 0=0
Oxlzc: O=f <
| Proect < ,
= Messages File Line *
A\ Warning[Lp006]: placement includes a mix of writable sections (example "rw data section DiworkyP \image2icf 136
image.entry.data in startup.o symbols: [gimage2EntryFunl]") and non-writable sections
(example "ro data section .image? walidate.rodata in startup.o symbols:
[RAM_IMG2_VALID_PATTEM]")

I Ferfarming FostBuild Action

Tatal number of errors: 0
Total number of warnings: 57

= Debuglog Buid

Errors 0, Warnings 57

How to set Break point is shown as follows:
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= 5
& Project - IAR Embedded Workbench IDE li‘ﬂlﬂ
Eile Edit View [Project| CMSIS-DAP Tools Window Help —
DS @[ AddAles. YYyeulrerdh U s|r
\Workspace Add Group... x (== | L] main() ~ x
Drebus I rt File List... = i " - ) —
q mport File Lis #}nclude wFreeRT?S.h set debugger =
Files Add Project Connection o B #include "task.h F
. z . #include "diag.h”
B 3 Project- [ Edit Configurations... #include ™
Ocmsis a
[Jconsole smeve extern woid Mlan_netowrk(wvoid);
[Tlik Create New Project... conscle_init({veid);
[ netwark o ; E
Cos Add Existing Project rief Main program.
[ petipher : #param None
[ polarss| Options.. Ale+F7 * gretval Nome
b— LI SDRAKM y|ov
Duser Wersion Control System ® void main(void)
3 Output Make F7 { N o
console init{);
Compile Crl+F7 //For ilNIC project, disable by default
Rebuild All #if CONFIG_INIC EN
inic_interface_init();
Clean sendiz = =
Batch build... F8
d | " #if defined(CONFIG_WIFI_NORMAL) =z defin
Project Stop Bui Ctrl+Breal =
| [ 4
* Download and Debug Ctrl+D
Messagas Debs thout load
Building ca ebug without Downloading | . __his oEtic n is currently not supported in this version! 1!
Updating Make & Restart Debugger Ctrl+
Restart Debugger Ctrl+Shift+R
Configurati Download v
SFR Setup
2« Open Device Description File [ S— D
E Save List of Registers..
Download the application and start the debugger Errors 0, Warnings 0 NU
\

By the way, ROM code and Boot loader code is provided by means of the symbol list tables,

rom_symbol_v01_iar.icf and bootloader_symbol.icf. You can find it in

project\realtek_amebaz_va0O_example\EWARM-RELEASE. So if you are tracking to the function

which is running in the ROM or boot loader area, the source code can’t be located.

May 2, 2017
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{& bootloader_symbolicf (DAWerk).._va0_sxampla\EWARM-RELEASE) - GVIM

[ESMEER )

SZAEHF)

#FHE) ITEM &S =hEE) sOMW) #=EEiH)

AaRDE| ® @

BIRREB SSATHAl? 2

define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define

exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported

symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol

/= Bootloader symbol list =/

BOOT_FLASH_InitDebugFlg = 0x@8808021;

BOOT_FLASH_PhaseCalibration = BxA8AB00037;

BOOT_FLASH_GetOption = 8x880088e1;
BOOT_FLASH_Calibration = B8xB880888f7;
BOOT_FLASH_GetUendor = Bx08000167;
BOOT_FLASH_Image1 = 8x08808233;
0TA_Valid = @x8888685c1;

0TA_Change = O0x880005e9;
0TA_Force1Check = 8x8888067b;
0TA_Select = Bx080006C3;
IMAGE1$$Base = 8x18002001;
RamStartTable = B8x188626801;
RAM_IMG1_VALID_PATTEN = 0x18002019;
BOOT_RAM_Image1p5 = 8x180028e1;
BOOT_RAM_WakeFromPG = B8x18882187;
BOOT_RAM_Imaged1 = 8x180821ed;
BOOT_System_Init1 = Bx18882269;
BOOT_System _Init2 = 8x10808226b;
SOCPS_SPSPin_Pull_RAM = 8x18882341;
SOCPS_PAD_CMD_RAM = Bx18882359;
SOCPS_SleepPG_RAM = Ox18002389;
SOCPS_FlashPin_PullUp_RAM = Bx188023ad;
SOCPS_DeepSleep_RAM = 8x100823d7;

<le\EWARM-RELEASE\bootloader_symbol.icf" 37L, 2116C

1,1

m

Ll

Tiidm

% rom_symbol_w01_iar.icf (D:\Work...wval_example\EWARM-RELEASE) - GVIM1

|c: =] .--?3--1

SZH(F)

FHE 1B HES) EHEE) s0OWw) | #EH)

AERE 9 @)

BRRERBSSAITED?

exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported

symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol

_ vectors_table = Oxd;
Reset_Handler = 8x161;
HMI_Handler = 8x115;
HardFault_Handler = 8x119;
MemManage_Handler = 8x12d;
BusFault_Handler = B%131;
UsageFault_Handler = 8x135;
USprintf = 8x281;
DiagPrintf = Bxidd;
DiagSPrintf = Ox589;
DiagSnPrintf = Bx535;
prubDiagPrintf = 8x7ed;
pruDiagSPrintf = 8x821;
UARTIMG_Write = Bx855;
UARTINMG_Download = 8x981;
_memcmp = Bx991;

_memcpy = @x9chH;

_memset = @xadd;
DumpForOneBytes = Bxae?;
CmdRomHelp = Bxcé?9;
CmdDumpWord = 8xccd;
cmdWriteWord = Oxd7d;
CmdFlash = B8xdd1;

CmdEfuse = Bx1Zc1;

<LEASEAZrom_symbol v@1_iar._.icf” [unix] 1424l , 71558C

May 2, 2017
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4 Image tool download

Please reference AN0112 Realtek Ameba-Z Image Tool user manual.doc.pdf for details.

Assuming that the Image Tool on PC is Server, which sends images files to Ameba-Z (Client)
through UART. Client or Server, whichever starts first will be ok.

Steps on Ameba-Z

Step 1: For QFN32, pins marked with “1”on the figure should be connected by jumper cap.
For QFN48 & QFN68, pins marked with “2”shouldbe connected by jumper cap.
Step 2: Push the Image Download Button and keep it pressed.

Step 3: Power on the board or press the Reset Button. Now Ameba-Z goes into UART
DOWNLOAD mode.

Step 4: Finally release the Image Download Button. Now the client is ready for receiving data.

l LOGUART: GPIOA_16 & GPIOA 17

Reset Button

Image
Download
Button

[ LoGUART: GPIOA_29 & GPIOA_30 |

Figure 4-1 AmebaZ DEV

Steps on image tool
May 2, 2017 16
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Step 1: Select serial port. The default baud rate is 1.5Mbps.

Step 2: Select transmission baud rate

Step 3: Open serial port

Step 4: Check the images to be transferred

Step 5: Select and load images files by browsing which are generated by IAR project.

Step 6: Input image addresses. The address which starts with 0x08 is for flash, and 0x10 for
RAM.

Step 7: Push Download button to start. Now the server is ready to send data.

May 2, 2017
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con:  comz Baudrate: 1500000
Flash Erase

Addr:  0x08000000

Boot: tbughwl9114_debughboot_all. bin Browse Addr] (hex):  Ox05000000
System: [ Browse Addr? (hex):
OTAl: 3114 _debughimageZ_all_otal. bin Browse #ddrd (hex):  Ox0S00EOOO
o0Taz: [ Browse AddrS (hex) :

D Browse 2ddrf (hes) :

D Browsze 2ddrT (hex):

image_all. bin Browse Ozx08000000

OTAL image: ]

COM1Z i= open successfnlly!

Uart dewrleoad serwer has started. ..
Koot image is being sent. ..

Boot image has been sent successfullyl
OTAl image iz being =ent. ..

OTAl image has been =zent successfullyl
511 images are sent successfully!
COM1Z 1= closed successfully!

@ I:‘ Single Image Mode

Figure 4-2 Image Download Tabpage

When the client and server are both ready, data transmission begins.

The progress bar will show the transmit progress of each image. You can also get the message
of operation successful or errors occur from log window.

5 How to use peripheral sample code
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There are several peripheral example code under folder “project\realtek_amebaz_va0_example

“;

\example_sources \”, you can copy & paste the example’s “inc” and “src” to project folder.

Ex. To use i2c example code, you can copy “src” and “inc” from “project\
realtek_amebaz_va0_example\example_sources\i2c\”.
project ;
, InC
realtek_ameba__.ad exemp'e_cap
EWARM-RELEASE

example_sources

src

gpio
gpio_irq
i2¢
pwm
spi

uart
uart_irq
wlan

wlan_

m

) Inc

sSrc

Ameba API follows MBED API. User can check MBED website for peripheral API.

6 How to debug Hardfault

The Hardfault log is Similar to the following figure:
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RTLE195A[HAL]: RO = 0x0
RTLB1954[HAL]: Rl = 0x1005a37a
RTLE195A[HAL]: R2Z = 0x6
RTLE195A[HAL]: R3 = 0x0

RTLE195A[HAL]: R12 = 0x1005fdab
RTLE195A[HAL] : LR = 0x1004d0bf
RTLE195A[HAL]: PC = 0xl001ce00
RTLE195A[HAL] : PSR = 0x60000000
RTLE195A[HAL]: BFAR = 0x8
RTL2195A[HAL] : CFSE = 0xZ0000
RTL21954[HAL] : HFSE = 0xd0000000
RTLE195A[HAL]: DFSR = 0x0
RTLE195A[HAL]: AFSR = 0x0
RTLE1954[HAL] : PriMask 0x0
RTL2195A[HAL] : BasePri 0x0
RTLE1954[HAL] : SVC priority: 0x00
RTL21954[HAL] : PendSVC priority: 0xf0

Firstly, you should record PC and LR register values.

Then open the application.asm in project\realtek_amebaz_va0_example\EWARM-
RELEASE\Debug\Exe and find PC and LR in which functions. The instruction pointed by PC is that
which caused system crash. And LR location shows who the caller of the crash function is.

If the value in PC register is in ROM (0x00000000~0x0007FFFF) or Boot loader area
(0x10002000 ~ 0x10004FFF), you can check rom_symbol_v01 _iar.icf or bootloader_symbol.icf
to locate the function by the symbol address.

For example, if PC = 0x38478, then hardfault is happened in the function “ctr_drbg_random”.

define exported symbol ctr_drbg_random_with_add = B8x383ad;
define exported symbol ctr_drbg_random = 0x38469;

define exported symbol des init = Bx388a5;

define exported symbol des free BxBBBh1E

define exported symbol des3 init = Bx388c5;

define exported symbol des3 free = Bx388d5;

If PC is not a valid memory address, may be memory overflow or get flash instruction error.

If you need more information, please contact us with UART LOG, EWARM-
RELEASE\Exe\application.asm and EWARM-RELEASE\Debug\application.map.

Please reference to Cortex-M3 Troubleshooting for more debug details.
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