2 REALTEK

Build Environment Setup — IAR

This document illustrates how to build Realtek Wi-Fi SoC software under IAR SDK
environment.
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1 How to get IAR

IAR provides an IDE environment for code building, downloading, and debugging. Please check
“IAR Embedded Workbench” on http://www.iar.com/, and trail version is available.

2 Ameba-Z Hardware Configuration

Hardware block diagram is shown in Figure 2-1 Hardware block diagram. The block USB UART
is used to supply power and catch logs, UART baud is 115200. SWD means J-Link SWD interface,
when it is connected to J-Link Adapter correctly, you can download images to Ameba-Z from
IAR flash downloader. Reset button is used to reset Ameba-Z to run firmware after IAR
completes downloading.

Reset button

? WIFI external ant

DAP update
mode button

50
i O)

RS+ pUE

e A R
USB Device

P 3 a ‘7

> SR

& = BVUART LOG: [
J 7 by o Bl PA29&:PA30
. 5% - f: L. ~al| Download image
DAP reset ) z 1 SEREI button

button

Figure 2-1 Hardware block diagram

The Dupont Line diagram between J-Link Adapter and Ameba-Z SWD is as follows:
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Figure 2-2 J-Link SWD connection

Please notice that DAP chip is not welding on the Ameba-Z demo board and so DAP function is
not enabled which means MBED u disk copy is disabled.

Physical connection as shown below:

Figure 2-3 Physical connection

3 How to build and download code

Please make sure USB UART is connected to PC with USB line and SWD is connect to J-Link
Adapter with Dupont Line before download code.
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3.11AR build

Step 1: Open IAR Workbench

Step 2: To open project, click File = Open = Workspace

Open

Close

Save Workspace
Close Workspace
Save

Save As...

Save All

Page Setup...
Print...

Recent Files

Recent Workspaces

Exit

Ctrl+P

YA e P EHBINURS|D D

» File...

Header/Source File

Ctrl+0

Ctrl+Shift+H

Guidelines for setting up
your project, adding
files, compiling, linking,
and debugging it.

TUTORIALS
Tuterials to make you
familiar with the IDE
and the features of the

|AR C-SPY debugger.

SER GUIDES
Complete product
documentaticn in PDF
format gives you all the
user and reference
information you need.

For questions about how
to use your |IAR product,
reporting a problem, or
finding support
resources.

5 //
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Ctrl+5 II

Example applications
that demonstrate
hardware peripherals for
specific devices and
evaluation boards.

All about the latest
features, new device
support, and program
comections.

? Al Al

Informaticn and
example projects for
integrated RTOS and
middleware sclutions.

¥y Fages
Here you can download
product updates,
manage licenses and
contact information, and
chedt your SUA status.

mn

Open a Workspace

MNUM

Step 3: Select Project.eww in project\realtek_amebaz_va0_example\EWARM-RELEASE

Click Project = Options, General Options->Target->Processor Variant->Core, make sure you
have chosen Cortex-M4f. If your IAR not support this core, Please choose Cortex-M4 and
Floating point settings->FPU is set to “VFPv4 single precision”.
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Files S
=fs]Project-Debug [ v | |

HE (dapp

FE@enss Optons for e rojec S~ €S

[Jconsole
[dlib
[ network, Categany:
[Jos
—E [ petipheral —
CJuser Static Analysis
L Runtime Checking
guotlhttll?? CJC++ Compiler Target |Qutput | Library Configuration | Library Options H:lLIL.
ulpu Assembler
Output COITIVEH:EF Processor wariant
Custom Build
Build Actions @ Core I[E"rte“_ll'll"'1 v]l
Linker =
' Debugger ) Dewice |Nonedefault Hone | |E|
Simulator
Angel
i CMSIS DAP Endian moda Floating peint settings
GDE Server . @ Little FFU ['LI"FPVQ single precisi
IAR ROM-monitor I Big I
Ljet/TTAGjet BESZ I 18 ~]
;Llsngljl—Trace @ ES
aris [ |hdvanced SIND (HEOH)
Macraigor
PE micro
RDI
STALINK
Third-Party Driver
Project
| TIXDS [ ok || Ccancel
Ready

Step 4: To build project, click Project - Rebuild All

Then you will get boot_all.bin and image2_all_otal.bin in
project\realtek_amebaz_va0_example\EWARM-RELEASE \Debug\Exe.
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rﬁ Project - [AR Embedded Workbench IDE
FEile Edit View |B | CMSIS-DAP  Tools Window Help
D W E Add Files...
Workspace Add Group._.
[Debug Import File List...
Files Add Project Connection...
B (7 Project - L Edit Configurations...
Cdemsis
& 1 console EEE
g lrit;t'-.n.rclrk Create New Project...
CJos Add Existing Project...
o
oo oine options. Alt+F7
— L1 SDRAM Version Control System ]
CJuser
3 Cutput Make F7
Compile Ctrl+F7
Rebuild All
Clean
Batch build... F&
Stop Build Ctrl+Break
Download and Debug Ctrl+D
Debug without Downloading
Make & Restart Debugger Ctrl+R
Restart Debugger Ctrl+Shift+R
Download J
5FR Setup
Im Open Device Description File ]
Clean and make the Save List of Registers... L
4

Step 5: To build image2_all_ota2.bin for OTA, click Project->Options->Build Actions->Build
Actions Configuration->Pre-build command line, change the secondary parameter “1” to “2”
shown as follows, then Click OK and build project. If project is not really built, please make a
little modification to a C file to be compiled and build again.

Then you will get image2_all_ota2.bin in project\realtek_amebaz_va0_example\EWARM-
RELEASE \Debug\Exe.
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Options for rode 'Project_ ., ==

Categary:

General Options
Static Analysis
Runtime Chedsing . . . . 5
| C/C++ Compiler Euild Actions Configwration |

Assembler T
Fre-build d line:
Qutput Converter re Eommanc Sine

Custom Eild Atycommontprebuild. vhe®| “$FROJ_DIERS I 1 I 008080000 E]

Build Actions Fost-tmild command line:
[

Linker C3CEIPT “$PREOT_DIREY. (M. .. . ‘compomenthsochrealtelhdT: E]
Debugger
Simulator
Angel
CMSIS DAP
GDE Server
TAR. ROM-monitor
IHet/TTAGjet
Hink/1-Trace
TI Stellaris
Macraigor
PE micro
RDI
STLIMK
Third-Party Driver
TILXDS [

Ok J[ Cancel ]

By the way, the mbed APIs include C files and Header files used by Ameba-Z is located in
component\soc\realtek\8711b\mbed\. It will also be merged to component\common\mbed\ in
next version. Now if you use Ameba-1, please choose files from component\common\mbed\
and if you use Ameba-Z, please choose files from component\soc\realtek\8711b\mbed\.
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= — —— B
& Project - IAR Embedded Workbench IDE =NACE X
File Edit View Project Tools Window Help
s-a=3- 1] | | - Ly vy
Workspace main.c | mainQ + X
[Debug - =2 —
B B -
il Sl ;P * gfhrief Maln program.
* @param None
Oos * @retval None
&= ?eriEheraI L &
s --_ vold main(woid)
analogin_api.c =M A
& [c] dma_apic uint32_t *p = (uint32_t*)0x10005010;
efuse_api.c
[ flash_api.c *p = 32;
gpio_api.c printf({™\np=id\n", *p);
gpio_irg_api.c
i2c_api.c = = if { rtl_cryptoEngine_inic{) != 0 ) {
i2s_api.c DiagPrintf({"crypte engine init failed\r\n"): =
nfc_api.c !
2 o
e p!nmap.c /% Initialize log uart and at command service */
pinmag_comman.c //console init():
port_spi.c . ReRegiste;Flat:'cr‘lri.cgUart [V
pwmout_api.c £
HC__aF"-C /* pre-processor of application example #/
serial_api.c

pre_example_entry():

I spi_api.c /# wlan intialization */

SWS_api.c [ #if defined(CONFIG_WIFI_NCRMAL) ss defined(CONFIG_NETWCRK)

timer_api.c wlan network():

us_ticker.c - #endif

[l us_ticker_apic 2

* Execut a licatl Xa 1 #
| Project or = / - Exscute application exampls / .
x n oL
= | nnt =
of ¢ | i -
pu |
A —
& Build Debuglog x
Ready
F——

3.2 1AR download

The Ameba-Z demo board only supports JLINK SWD download and debug.

Please note that if you want use IAR download image to debug, please set the secondary

parameter of prebuild.bat to “1” and build.

Step 1: Please check J-link debugger is setting correct. Click Project->Options->Debugger-
>Setup->Driver, and choose “J-Link/J-Trace”. Then click Debugger-> J-Link/J-Trace->Connection-

>Interface and choose “SWD”.
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-
& Project - IAR Embedded Workbench IDE

= B ®

File Edit View |

-
Options for node "Project

S

D &
ies= 1§
Dreb :
Files General Options
=l Ifl Static Analysis
Clal Runtime Checking
0 Cr[':Ir'IFJSiS €/C++ Compiler Setup |Download I Images I Extra Options | Multicore I Plugins|
[Jconsole Assembler )
Clib Output Converter Nriver Fun to
Custom Build J-Link/T-Trace - main
[ network, I I—I
Build Actions Tetnp macres
Clos ; Linker )
[:Iperlpher | [V]Uze macro filelz)
[:I user Simulator FFROT_DIEEY. . % . % . ‘componentisochrealtelhd@T11bimi D
[ utilities Angel
3 Qutput CMSIS DAP E]
GDEB Server . L .
IAR ROM-monitor Dlevice deseription file
THet/TTAGet Owverride default
J-Link/J-Trace FFROT_DIEEY. % . % . hcomponenthisochrealtelh@T11b'mi D
T1 Stellaris
- Macraigor
I Project PE micro
" RDI
tessages ST-LINK
P Third-Party Driver
Linking i
M wWarninglL [ 0K ] [ Cancel
"zi sectiaon .
Ay Waming[Lp : .
data section .imagel validate.rodata in startup.o symbols: [RAM_IMGEZ _WALID_FPATTEMN]"M
Fertarming Post-Build Action
3
Taotal number of errors: 0 j‘
= b P Y ey R Y .
= N 3
Ready Errors 0, Warnings 57
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¥ I
& Project - IAR Embedded Workbench IDE l_‘:' I
. : . -
File Edit Viewy Options for node "Project™ ﬂ
D &
ies= 1§
Drebu : -
[ 8 Lty Factory Settings
Files General Options
o TR | |Sttc s
Runtime Checking
[a . ;
DcfﬂpSiS C/C++ Compiler Connection |Breakpoints
[Jconsole Assembler Commund cation
C1lib COutput Converter @ Dlewice O | Serial
Custom Build _
() ICESTE: IF addr
& (1 network, Build Actions IV ICES addrezs
EUS Linker IF address: |aaa bbb cee. ddd Serial
eripharg
Rernp Debugger Interface JTAG scan chain
[user Simulator L .
L@ 7 utilities Angel ) ITAG JTAG =can chain with multiple tar
3 Qutput CMSIS DAP @ SN T mmber: 0
GOB Server T Secan chain contains non—AEM device
IAR ROM-monitor Preceeding a
T4et/TTAGiet
DLog communication
i TI Stellaris $FROT_DIES  czpweomm. Loz
- Macraigor
I Project PE micro
" RDI
tessages ST-LINK
P Third-Party Driver
Linking i
Ay Warming[Lp|| ok ] [ Cancel
"zi sectiaon .
Ay Waming[Lp : .
data section .imagel validate.rodata in startup.o symbols: [RAM_IMGEZ _WALID_FPATTEMN]"M
Fertarming Post-Build Action
3
Taotal number of errors: 0 j‘
g i P WU [ vRpRy T S UPRPE P PO ater
= N T 3
Ready Errors 0, Warnings 57

Step 2: To download code, click Project->Download->Download active application.
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= - F—*— B
& Project - IAR Embedded Workbench IDE ™~ Elég

File Edit View [Project| Tools Window Help

(D& G| AddFles. Y2 iE e @ » & |
Add Group... - X

Debug Import File List...
Files Add Project Connection...
=f&]Project - [ Edit Configurations...
CDapp
1 Clcmsis HErEoE
= C,DnSDIB Create New Project...
—& [1lib o )
[T netwark Add Existing Project...
[dos .
. Opti Alt+F7
| & [ peripher Sl *
Cluser Version Control System 3
[ utilities
[ Output Make F7
Compile Ctrl+F7
i Rebuild all
Clean
Batch build... F&
[ Priect C-STAT Static Analysis »
x
Messages Stop Build Ctrl+Break =
Linking
Ay Warming[L LETE DR example "rw data section .image. entry.da
vz section Debug without Downloading
I A warning[L Make & Restart Debugger ctrl+R  imple "rw data section image?. entry.data in
data SEF:“D Restart Debugger Ctrl+Shift+R Ge_VALID_PATTEN]')
Fertorming
Download 3 Download active application Ctrl+D
. I?t?! numll: SFR Setup Download file...
=K Erase memaory
Open Device Description File »

After firmware download, click Reset button to reboot the system.

3.31AR debug

To debug or trace code step by step, click Project 2 Download and Debug or press one of the

two buttons 2 L inthe IAR menu.

Upper left corner of the toolbar shows step by step tracking tools.
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Z Project - IAR Embedded Workbench P— =
File Edit View Project Debug Disassembly J-Link Tools Window Help
DL S % BRalo | AaA N LEEX FIEELY 1T
[E- T8 22 2ZZZTX] ,
D T
Workspace x - x Disassembly x
[Debug - Goto hd
Files ir B Disassembly &
B (FProject-D... « (4
HHE Cdapp 0x=l04: 0O=6
HH (1 cmsis 0xl06: O=f
H® [(Jconsale Nzlla: 0=z6
=ik 0xl0c: O=f
& (3 network 0x110: Oxf
[(Jas O0=114: 0=f
[ peripheral 0x11%: O=f
HE (] user 0zllc: O=E
& [ utilities Oxlle: Oxf
& [ Output 0=122: 0=f
O=1Z26: 0=t
O=xlZa: 0=0
0xl2c: O=f -
I Praoject <« L] 3
* hessages File Line *
My WWarning[LpO06]: placernent includes a mix of writable sections (example "rw data section DiwvarkiP . Aimage2.icf 136
imaged. entry.data in statup.o symbaols: [glmage2EntryFund]") and nor-writable sections
[example "ro data section imagevalidate rodatain startup.o symbols:
[RAM_IMGZ_WALID_PATTEMN]"
I Ferforming Fost-Build Action
|
Total number of errars: 0 I
Tatal number of warnings: 57 1
x

Errors 0, Warnings 57

How to set Break point is shown as follows:
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iR B
& Project - IAR Embedded Workbench IDE lilﬂlg
File Edit View fErcg'ed] CMSIS-DAP  Tools Window Help
D W& AddFiles. sy rerdah|nmUAL L L
Workspace Add Group... * | main | main() v X
Debug Import File List... - ; e - 1 =l
P #:.anlude “FreeRI(:S.h set debugger ..
Files Add Project Connection... g B #include "task.h T
R . . #include "diag.h"
B Project - [ Edit Configurations... v #include "main.h"
[Dcmsis
[Jconsole Remove extern void #lan netowrk(void);
[Tlib Create New Project.. conscle_init(void);
= [ network o _ = E
Clos Add Existing Project... N Main program.
[ peripher ] None
[ palarss! Clptions... Alt+F7 « gretval Nome
— CISDRAM Wersion Control System 3 v \"‘— _*; ) .
[Tuser @ void main(void)
3 Dutput Make 7 =i a
_ console_init{);
Compile Ctrl+F7 //For illIC project, disable by default
Rebuild All 5] #if CONFIG_INIC_EN
Clean inic_interface_init{):
r #endif
Batch build... F&
I:T] #1f defined (CONFIG WIFI_NORMAL)} == defin
| Project Stop Build Ctrl+Break o =
x Download and Debug Ctrl+D I
Messages — pu
Building co ebug without Bownloading | < _This ogtic n is currently not supported in this version!!!
Updating b IMake 8 Restart Debugger Ctrl+
Restart Debugger Ctrl+Shift+R
Configurati Download D
SFR Setup
2| « I Open Device Description File ] :I o
é Save List of Registers...
Download the application and start the debugger Errors 0, Warnings 0 MU

S ————————————————————————————————————

By the way, ROM code and Boot loader code is provided by means of the symbol list tables,
rom_symbol_vO01 iar.icf and bootloader_symbol.icf. You can find it in
project\realtek_amebaz_va0_example\EWARM-RELEASE. So if you are tracking to the function
which is running in the ROM or boot loader area, the source code can’t be located.

November 18, 2016
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{# bootloader_symbol.icf (DA\Worl\... va0_example\EWARM-RELEASE) - GVIM

=

=RRCIR X

ZER H&mE|E TERM OEE#ES SaEE) s0OW)  E8H)
O B @ |

BIRREL|ISSA|[TaAC ? 2

/= Bootloader symbol list =/

define exported symbol BOOT_FLASH GetOption = 8xB8@888e1;
define exported symbol BOOT_FLASH _Calibration = BxB880068F7;
define exported symbol BOOT_FLASH GetUendor = OxB8800167;
define exported symbol BOOT_FLASH Imagel = 8x0880888233;
define exported symbol 0TA_Valid = 8x82808085c1;

define exported symbol BOOT_FLASH_InitDebugFlg = B8x88800021;
define exported symbol BOOT_FLASH_PhaseCalibration = @x88000037;

define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported
define exported

symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol

O0TA_Change = 8x88
0TA_ForcelCheck =
0TA_Select = BxA88
IMAGE1$5Base = 8z
RamStartTable = 8
RAM_IMG1_UVALID PA
BOOT_RAM_Image1p5
BOOT_RAM_WakeFrom
BOOT_RAM _Image1l =
BOOT_System_Init1
BOOT_System_Init2

a0a5e?;
BxB8800067h ;
8e86c3;
188820801 ;
x180820881;

TTEN = B8x18882019;
= Bx10086820e1;
PG = 8x18882187;

Bx100021ed;
= Bx10082269;
= Bx1088226b;

SOCPS_SPSPin_Pull_RAM = Bx18882341;

SOCPS_PAD_CHD_RAM
SOCPS_SleepPG_RAM
SOCPS_FlashPin_Pu

= Bx18882359;
= Bx10082389;

11Up_RAM = Bx1880823ad;

SOCPS_DeepSleep_RAM = 8x188023d7;

<le\EWARM-RELEASE\bootloader_symbol .icf™ 37L, 2116C

1,1

m

2l

Thim

% rom_symbol_v01_iarict (D\Work..va0_example\EWARM-RELEASE) - GVIM1

[ESREERT=)

MR &EE) TR EEES SdEE) s0W) | EaiH)

aAadRsd |9 |

BIRREBB(SSA[TRO ? R

efine exported
define exported
define exported
define exported
define exported

symbol
symbol
symbol
symbol
symbol

__wvectors_table =
Reset_Handler = A8
HHMI_Handler = 0x1
HardFault_Handler
MemiManage Handler

Bx8;
x181;
153

= Bx119;
= Bx12d;

define exported symbol BusFault_Handler = 8x131;
define exported symbol UsageFault_Handler = 8x135;
define exported symbol USprintf = Bx201;

define exported symbol DiagPrintf = Bxidd;

define exported symbol DiagSPrintf = 8x589;

define exported symbol DiagSnPrintf = 8x535;
define exported symbol pruDiagPrintf = Bx7ed;
define exported symbol pruDiagSPrintf = Bx821;
define exported symbol UARTIMG_Write = Bx855;
define exported symbol UARTIMG_Download = 8x9081;
define exported symbol memcmp = B8x991;

define exported symbol memcpy = Bx9ch;

define exported symbol _memset = Bxa7d;

define exported symbol DumpForOneBytes = Bxae?;
define exported symbol CmdRomHelp = Bxcé69;

define exported symbol CmdDumpWord = Bxccd;

define exported symbol CmdWriteWord = 8xd7d;
define exported symbol CmdFlash = Bxddi;

define exported symbol CmdEfuse = Bx12c1;
<LEASEZrom_symbol w81 iar.icf'" [unix] 1424L, 71558C

2l

Tiilm
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4 Image tool download

Please reference WS_20160928 WLAN5_ AmebaZ Image_Tool User_ Guide_1vO0.pdf for details.

Assuming that the Image Tool on PC is Server, which sends images files to Ameba-Z (Client)
through UART. Client or Server, whichever starts first will be ok.

Steps on Ameba-Z

Step 1: For QFN32, pins marked with “1”on the figure should be connected by jumper cap.
For QFN48 & QFN68, pins marked with “2”shouldbe connected by jumper cap.
Step 2: Push the Image Download Button and keep it pressed.

Step 3: Power on the board or press the Reset Button. Now Ameba-Z goes into UART
DOWNLOAD mode.

Step 4: Finally release the Image Download Button. Now the client is ready for receiving data.

[ LOGUART: GPIOA_16 & GPIOA 17

Reset Button

Image
Download
Button

[ LoGUART: GPIOA_29 & GPIOA_30 |

Figure 4-1 AmebaZ DEV

Steps on image tool
November 18, 2016 16
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Step 1: Select serial port. The default baud rate is 1.5Mbps.

Step 2: Select transmission baud rate

Step 3: Open serial port

Step 4: Check the images to be transferred

Step 5: Select and load images files by browsing which are generated by IAR project.

Step 6: Input image addresses. The address which starts with 0x08 is for flash, and 0x10 for
RAM.

Step 7: Push Download button to start. Now the server is ready to send data.

November 18, 2016
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Dowrlosd |Generate

Serial
Com: Com4 (1)~ Bandrate: 1500000 (2]« . Opan

Feasd/Fraze Flash Fesdffirite Statusl Regiszter
fddr: 008000000 Yalue: 1200
Jize: 4

I Read I I Erasze

(4)
Esot: [¥] boot_all bin Erowse Addrl (hex]:  Ox0BO00000

Swrstem: || Browse A dr? (hex):
Calib: 1] Erowse mdde Chex):
oTal: [ Addrd Chex):
OTAZ: Addrs Chex):
User: Addrd (hax )
RIF: 8437 (hax:

A11: inage_all. bin 51dr3 (hex ) | 008000000

7] [[] Single Imzge Mode

Figure 4-2 Image Download Tabpage

When the client and server are both ready, data transmission begins.

The progress bar will show the transmit progress of each image. You can also get the message
of operation successful or errors occur from log window.
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5 How to use peripheral sample code

There are several peripheral example code under folder “project\realtek_amebaz_va0_example
\example_sources \”, you can copy & paste the example’s “inc” and “src” to project folder.

Ex. To use i2c example code, you can copy “src” and “inc” from “project\
realtek_amebaz_va0_example\example_sources\i2c\”.

project
realtek_ameba__.ad exemp'e_cap
EWARM-RELEASE

example_sources
gpio
gpio_irq
i2¢
pwm
spi
uart
uart_irq
wlan

wlan_

m

inc

src

Ameba API follows MBED API. User can check MBED website for peripheral API.

6 How to debug Hardfault

The Hardfault log is Similar to the following figure:

November 18, 2016
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RTLE195A[HAL]: RO = 0x0
RTLB1954[HAL]: Rl = 0x1005a37a
RTLE195A[HAL]: R2Z = 0x6
RTLE195A[HAL]: R3 = 0x0

RTLE195A[HAL]: R12 = 0x1005fdab
RTLE195A[HAL] : LR = 0x1004d0bf
RTLE195A[HAL]: PC = 0xl001ce00
RTLE195A[HAL] : PSR = 0x60000000
RTLE195A[HAL]: BFAR = 0x8
RTL2195A[HAL] : CFSE = 0xZ0000
RTL21954[HAL] : HFSE = 0xd0000000
RTLE195A[HAL]: DFSR = 0x0
RTLE195A[HAL]: AFSR = 0x0
RTLE1954[HAL] : PriMask 0x0
RTL2195A[HAL] : BasePri 0x0
RTLE1954[HAL] : SVC priority: 0x00
RTL21954[HAL] : PendSVC priority: 0xf0

Firstly, you should record PC and LR register values.

Then open the application.asm in project\realtek_amebaz_va0_example\EWARM-
RELEASE\Debug\Exe and find PC and LR in which functions. The instruction pointed by PC is that
which caused system crash. And LR location shows who the caller of the crash function is.

If the value in PC register is in ROM (0x00000000~0x0007FFFF) or Boot loader area
(0x10002000 ~ 0x10004FFF), you can check rom_symbol_vO01 iar.icf or bootloader_symbol.icf
to locate the function by the symbol address.

For example, if PC = 0x38478, then hardfault is happened in the function “ctr_drbg_random”.

define exported symbol ctr_drbg_random_with_add = B8x383ad;
define exported symbol ctr_drbg_random = 0x38469;

define exported symbol des init = Bx388a5;

define exported symbol des free BxBBBh1E

define exported symbol des3 init = Bx388c5;

define exported symbol des3 free = Bx388d5;

If PC is not a valid memory address, may be memory overflow or get flash instruction error.

If you need more information, please contact us with UART LOG, EWARM-
RELEASE\Exe\application.asm and EWARM-RELEASE\Debug\application.map.

Please reference to Cortex-M3 Troubleshooting for more debug details.
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